Last modified November 22, 2014 by Gordon Glauser

SDK Feature Support Matrix

This article provides information about the features supported by Swrve’s SDKs for each version of Android, iOS, Unity Android and Unity iOS.

Support Matrix

 

Android

The table below details the features support by Swrve’s Android SDK1 for each Android version.

Android Version Analytics In-App Messaging Push Notifications1
2.0.1 – 3.2.x2 N N N
4.0 and later Y Y Y

Notes:

1Google Play and Amazon flavours only.

2For Android 2.2.x to 3.2.X version devices (such as API Level 8 and Froyo), Swrve’s Android SDK gracefully does nothing (that is, it does not send any data or campaigns; it acts as a dummy SDK).

iOS

The table below details the features support by Swrve’s iOS SDK1 for each iOS version. The Swrve iOS SDK supports iOS 6 and later.

iOS Version Analytics In-App Messaging Push Notifications
6 – 72 N N N
8 and later Y Y Y

1Swrve’s iOS SDK requires that you use iOS version 6 or later.

2For iOS 6 and 7 Swrve’s iOS SDK gracefully does nothing (that is, it does not send any data or campaigns; it acts as a dummy SDK).

Unity Android

The table below details the features support by Swrve’s Unity SDK1 for each Android version.

Android Version Analytics In-App Messaging Push Notifications2
2.0.1 – 3.2.x2 N N N
4.0 and later Y Y Y

Notes:

1Swrve’s Unity SDK requires that you use Unity version 4.0.0 or later. Push Notifications are supported in Google Play and Amazon flavours only.

2For Android 2.2.x to 3.2.X version devices (such as API Level 8 and Froyo), Swrve’s Android SDK gracefully does nothing (that is, it does not send any data or campaigns; it acts as a dummy SDK).

Unity iOS

The table below details the features support by Swrve’s Unity SDK1 for each iOS version.

iOS Version Analytics In-App Messaging Push Notifications
6 – 72 N N N
8 and later Y Y Y

Notes:

1Swrve’s Unity SDK requires that you use Unity version 4.0.0 or later.

2For iOS 6 and 7 Swrve’s iOS SDK gracefully does nothing (that is, it does not send any data or campaigns; it acts as a dummy SDK).


Unsupported Versions

Swrve does not currently support the following:

  • Unity Web Player
  • Unity Windows
  • Windows 8 (native)